Jump to content

Recommended Posts

Dobrý den, mám problem s javou. Když jsem provedl tenhle příkaz: 

java -Xms1G -Xmx2G -jar server.jar

tak se v powershellu ukázak error: 

 

Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/bukkit/craftbukkit/bootstrap/Main has been compiled by a more recent version of the Java Runtime (class file version 60.0), this version of the Java Runtime only recognizes class file versions up to 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$100(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

 

Mám nejnovjejší java. Nevíte někdo co stím je?

Odkaz na příspěvek
Sdílet na ostatních sítích

Sice máš nejnovější Javu (předpokládám, že z portálu https://java.com/en/, ale to je pouze JRE (v8), neboli Java Runtime Enviroment. Vzhledem k tomu, že projekty v Javě jsou vyvíjeny pomocí JDK, neboli Java Development Kit (Oracle: https://www.oracle.com/java/technologies/downloads/), součástí takového kitu je právě JRE. Co tedy potřebuješ je JDK. Vzhledem k verzi doporučuju 16 nebo 17, ty by měly 60.0 přelouskat bez problému.

Odkaz na příspěvek
Sdílet na ostatních sítích

Ke komentování se musíte přihlásit nebo si vytvořit účet

K zanechání komentáře musíte být člen

Vytvořit účet

Vytvořte si nový účet v naší komunitě.

Zaregistrovat se

Přihlásit se

Už máte účet? Přihlašte se zde.

Přihlásit se teď
×
×
  • Vytvořit nové...